const regex = /getopt(?:s|)(?: (?:-[a-zA-Z])*)*(?'name'[$a-zA-Z]+|)\s(?:(?:-o|--options) (?'short'.+) (?:-l|--longoptions|--long) (?'long'(?:[a-zA-Z0-9]|,|:|\$)+) \-\- \"\$@\"|(?:(?:(?:-[a-zA-Z])*|)\s*\"(?'while'(?:[a-zA-Z0-9]|,|:|\$)+)\"))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('getopt(?:s|)(?: (?:-[a-zA-Z])*)*(?\'name\'[$a-zA-Z]+|)\\s(?:(?:-o|--options) (?\'short\'.+) (?:-l|--longoptions|--long) (?\'long\'(?:[a-zA-Z0-9]|,|:|\\$)+) \\-\\- \\"\\$@\\"|(?:(?:(?:-[a-zA-Z])*|)\\s*\\"(?\'while\'(?:[a-zA-Z0-9]|,|:|\\$)+)\\"))', 'gm')
const str = `while getopts -a ":n:t:" options; do
while getopts -a -n ":n:t:" options; do
while getopt ":n:t:" options; do
Parameters=\$(getopt -a -n \$ScriptName --options \$SHORT --longoptions \$LONG -- "\$@")
Parameters=\$(getopt -a -n alphabet -o abc:d: --long alpha,bravo,charlie:,delta: -- "\$@")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}