# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"getopt(?:s|)(?: (?:-[a-zA-Z])*)*(?'name'[$a-zA-Z]+|)\s(?:(?:-o|--options) (?'short'.+) (?:-l|--longoptions|--long) (?'long'(?:[a-zA-Z0-9]|,|:|\$)+) \-\- \"\$@\"|(?:(?:(?:-[a-zA-Z])*|)\s*\"(?'while'(?:[a-zA-Z0-9]|,|:|\$)+)\"))"
test_str = ("while getopts -a \":n:t:\" options; do\n"
"while getopts -a -n \":n:t:\" options; do\n"
"while getopt \":n:t:\" options; do\n"
"Parameters=$(getopt -a -n $ScriptName --options $SHORT --longoptions $LONG -- \"$@\")\n"
"Parameters=$(getopt -a -n alphabet -o abc:d: --long alpha,bravo,charlie:,delta: -- \"$@\")")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.