import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\s*(;))\\s*[\\d.]+\\s*";
final String string = "2 MG/ML\n"
+ "500 MCG\n"
+ "100 MG ; 200 MG ; 200 MCG\n"
+ "100 MCG/ML\n"
+ "325 MG ; 37.5 MG\n"
+ "60 G ; 9 G/1000 ML";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}