re = /(?:^|\s*(;))\s*[\d.]+\s*/m
str = '2 MG/ML
500 MCG
100 MG ; 200 MG ; 200 MCG
100 MCG/ML
325 MG ; 37.5 MG
60 G ; 9 G/1000 ML'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result