using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.*), [0-9]{4}\)";
string input = @"Bonjour (auteur1 (ces parenthèses ne font pas échouer), 1999) et aurevoir (auteur2, 2001).";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}