re = /\((.*), [0-9]{4}\)/m
str = 'Bonjour (auteur1 (ces parenthèses ne font pas échouer), 1999) et aurevoir (auteur2, 2001).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end