package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)\((.*), [0-9]{4}\)`)
var str = `Bonjour (auteur1 (ces parenthèses ne font pas échouer), 1999) et aurevoir (auteur2, 2001).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}