const regex = /\((.*), [0-9]{4}\)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.*), [0-9]{4}\\)', 'mg')
const str = `Bonjour (auteur1 (ces parenthèses ne font pas échouer), 1999) et aurevoir (auteur2, 2001).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}