const regex = /(\s|^)(?s)\d{1,3}+\/+\s+.*?(?=\d+\/+\s+|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s|^)(?s)\\d{1,3}+\\\/+\\s+.*?(?=\\d+\\\/+\\s+|$)', 'gm')
const str = `1/ This is a string and it
has some text on a new line
2/ And then there's another string that has text only on one line
532/ Another string that has some year on a new line
2020/xyz followed by some letters
721/ And this is the last line `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}