#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^::[A-z ])(.*?)(?=$)"
Local $sString = "This is a test ::a. MODE 3 within 7 hours," & @CRLF & _
"" & @CRLF & _
"::b. MODE 4 within 13 hours, and" & @CRLF & _
"" & @CRLF & _
"::c. MODE 5 within 37 hours" & @CRLF & _
"" & @CRLF & _
":: My Test" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")