$re = '/(?<=^::[A-z ])(.*?)(?=$)/m';
$str = 'This is a test ::a. MODE 3 within 7 hours,
::b. MODE 4 within 13 hours, and
::c. MODE 5 within 37 hours
:: My Test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);