use strict;
my $str = 'This is a test ::a. MODE 3 within 7 hours,
::b. MODE 4 within 13 hours, and
::c. MODE 5 within 37 hours
:: My Test
';
my $regex = qr/(?<=^::[A-z ])(.*?)(?=$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}