const regex = /(?<=^::[A-z ])(.*?)(?=$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^::[A-z ])(.*?)(?=$)', 'gm')
const str = `This is a test ::a. MODE 3 within 7 hours,
::b. MODE 4 within 13 hours, and
::c. MODE 5 within 37 hours
:: My Test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}