# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#{1,6}//gm;t' <<< "# Heading 1
## Heading 2
### Heading 3
#### Heading 4
##### Heading 5
###### Heading 6"