$re = '/#{1,6}/m';
$str = '# Heading 1
## Heading 2
### Heading 3
#### Heading 4
##### Heading 5
###### Heading 6';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;