import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#{1,6}";
final String string = "# Heading 1\n"
+ "## Heading 2\n"
+ "### Heading 3\n"
+ "#### Heading 4\n"
+ "##### Heading 5\n"
+ "###### Heading 6";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}