#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)#{1,6}"
Local $sString = "# Heading 1" & @CRLF & _
"## Heading 2" & @CRLF & _
"### Heading 3" & @CRLF & _
"#### Heading 4" & @CRLF & _
"##### Heading 5" & @CRLF & _
"###### Heading 6"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)