package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(LLC|CO|CORP|DIV)\b`)
var str = ` TEST LLC TEST CO TEST CORP TEST DIV
COMPUTING DEVICES CO DIV CLDC `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}