const regex = /\b(LLC|CO|CORP|DIV)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(LLC|CO|CORP|DIV)\\b', 'gm')
const str = ` TEST LLC TEST CO TEST CORP TEST DIV
COMPUTING DEVICES CO DIV CLDC `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}