import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\")([1-9]\\d{0,2}(?:,\\d{3}){2,}|[1-9]\\d{1,2},\\d{3})(?:\")";
final String string = "\"10,400,000\",\"10,900,000\",\"500,000\",\"1,400,000\",\"1,900,000,123,564\",\"50,000\",\",050,000\",\"50,00000\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}