// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:")([1-9]\d{0,2}(?:,\d{3}){2,}|[1-9]\d{1,2},\d{3})(?:")"#).unwrap();
let string = "\"10,400,000\",\"10,900,000\",\"500,000\",\"1,400,000\",\"1,900,000,123,564\",\"50,000\",\",050,000\",\"50,00000\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}