$re = '`(?:")([1-9]\d{0,2}(?:,\d{3}){2,}|[1-9]\d{1,2},\d{3})(?:")`m';
$str = '"10,400,000","10,900,000","500,000","1,400,000","1,900,000,123,564","50,000",",050,000","50,00000"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);