import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"*([^\\s\"]+@[^\\s\"]+)\"* +<(?!\\1>)[^>]*>$";
final String string = "##THESE SHOULD NOT MATCH\n"
+ "###PART BEFORE THE LAST < DOSE NOT CONTAIN @\n"
+ "this example <this@example.com>\n"
+ "\"this example\" <this@example.com>\n"
+ "Name <this@example.com>\n"
+ "\"Name\" <this@example.com>\n"
+ "this@example.com\n"
+ " <this@example.com>\n\n"
+ "##THESE SHOULD NOT MATCH\n"
+ "###PART BEFORE THE LAST < CONTAINS @, HOWEVER BOTH STRINGS ARE IDENTICAL\n"
+ "\"this@example.tld\" <this@example.tld>\n"
+ "this@example.tld <this@example.tld>\n\n"
+ "##THESE SHOULD NOT MATCH\n"
+ "###PART BEFORE THE LAST < CONTAINS SPACE\n"
+ "\"random @ other.com\" <this@example.tld>\n"
+ "random @ other.com <this@example.tld>\n\n\n"
+ "#THESE SHOULD MATCH\n"
+ "alpha@example.com <beta@example.com>\n"
+ "\"alpha@example.com\" <beta@example.net>\n"
+ "alpha@other.tld <beta@example.com>\n"
+ "\"alpha@other.tld\" <alpha@example.com>\n"
+ "prefix@example.edu <prefix@example.edu.com>\n"
+ "\"prefix@example.edu\" <prefix@example.edu.com>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}