re = /^"*([^\s"]+@[^\s"]+)"* +<(?!\1>)[^>]*>$/m
str = '##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < DOSE NOT CONTAIN @
this example <this@example.com>
"this example" <this@example.com>
Name <this@example.com>
"Name" <this@example.com>
this@example.com
<this@example.com>
##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < CONTAINS @, HOWEVER BOTH STRINGS ARE IDENTICAL
"this@example.tld" <this@example.tld>
this@example.tld <this@example.tld>
##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < CONTAINS SPACE
"random @ other.com" <this@example.tld>
random @ other.com <this@example.tld>
#THESE SHOULD MATCH
alpha@example.com <beta@example.com>
"alpha@example.com" <beta@example.net>
alpha@other.tld <beta@example.com>
"alpha@other.tld" <alpha@example.com>
prefix@example.edu <prefix@example.edu.com>
"prefix@example.edu" <prefix@example.edu.com>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end