use strict;
my $str = '##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < DOSE NOT CONTAIN @
this example <this@example.com>
"this example" <this@example.com>
Name <this@example.com>
"Name" <this@example.com>
this@example.com
<this@example.com>
##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < CONTAINS @, HOWEVER BOTH STRINGS ARE IDENTICAL
"this@example.tld" <this@example.tld>
this@example.tld <this@example.tld>
##THESE SHOULD NOT MATCH
###PART BEFORE THE LAST < CONTAINS SPACE
"random @ other.com" <this@example.tld>
random @ other.com <this@example.tld>
#THESE SHOULD MATCH
alpha@example.com <beta@example.com>
"alpha@example.com" <beta@example.net>
alpha@other.tld <beta@example.com>
"alpha@other.tld" <alpha@example.com>
prefix@example.edu <prefix@example.edu.com>
"prefix@example.edu" <prefix@example.edu.com>
';
my $regex = qr/^"*([^\s"]+@[^\s"]+)"* +<(?!\1>)[^>]*>$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}