#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=([aui]))[wy](?=\1)|(?<=i)[wy](?=u)"
Local $sString = "asdawasda" & @CRLF & _
"asdayasda" & @CRLF & _
"asdiwisda" & @CRLF & _
"asdiyisda" & @CRLF & _
"asduwusda" & @CRLF & _
"asduyusda" & @CRLF & _
"" & @CRLF & _
"asdawisda" & @CRLF & _
"asdawusda" & @CRLF & _
"" & @CRLF & _
"asdayisda" & @CRLF & _
"asdayusda" & @CRLF & _
"" & @CRLF & _
"asdiwasda" & @CRLF & _
"asdiwusda" & @CRLF & _
"" & @CRLF & _
"asdiyasda" & @CRLF & _
"asdiyusda" & @CRLF & _
"" & @CRLF & _
"asduwasda" & @CRLF & _
"asduwisda" & @CRLF & _
"" & @CRLF & _
"asduyasda" & @CRLF & _
"asduyisda" & @CRLF & _
"" & @CRLF & _
"ramiyun" & @CRLF & _
"da9iwun"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)