package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`CN=(?P<first>[^,]+),\s*
(?P<last>[^,]+)`)
var str = `CN=First\, Last,OU=Standard users,OU=Users,OU=Place,OU=DOMAIN,DC=dfe,DC=stuff,DC=asdf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}