$re = '/CN=(?P<first>[^,]+),\s*
(?P<last>[^,]+)/x';
$str = 'CN=First\\, Last,OU=Standard users,OU=Users,OU=Place,OU=DOMAIN,DC=dfe,DC=stuff,DC=asdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);