use strict;
my $str = 'CN=First\\, Last,OU=Standard users,OU=Users,OU=Place,OU=DOMAIN,DC=dfe,DC=stuff,DC=asdf';
my $regex = qr/CN=(?P<first>[^,]+),\s*
(?P<last>[^,]+)/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}