re = /CN=(?P<first>[^,]+),\s*
(?P<last>[^,]+)/x
str = 'CN=First\\, Last,OU=Standard users,OU=Users,OU=Place,OU=DOMAIN,DC=dfe,DC=stuff,DC=asdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end