use strict;
my $str = '123456789123456789123456789
123456789
1234567
123456781234567812345678.11';
my $regex = qr/(?!^)(?=(?:\d{3})+(?!\.|\d))/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";