$re = '/(?!^)(?=(?:\d{3})+(?!\.|\d))/m';
$str = '123456789123456789123456789
123456789
1234567
123456781234567812345678.11';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;