import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+(?:\\\\t[^\\\\]*(?:\\\\(?![trn])[^\\\\]*)*){2}(?:\\\\r)?(?:\\\\n)$";
final String string = "23456\\thttp://some.url/path/to/resource\\t\\x03U\\x1D\\x1F\\x04D0B0@\\xA0>\\xA0<\\x86:http://some.url/path/to/resource\\x06\\x08+\\x06\\x01\\x05\\x05\\x07\\x01\\x01\\x04C0A0?\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}