const regex = /^[0-9]+(?:\\t[^\\]*(?:\\(?![trn])[^\\]*)*){2}(?:\\r)?(?:\\n)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+(?:\\\\t[^\\\\]*(?:\\\\(?![trn])[^\\\\]*)*){2}(?:\\\\r)?(?:\\\\n)$', '')
const str = `23456\\thttp://some.url/path/to/resource\\t\\x03U\\x1D\\x1F\\x04D0B0@\\xA0>\\xA0<\\x86:http://some.url/path/to/resource\\x06\\x08+\\x06\\x01\\x05\\x05\\x07\\x01\\x01\\x04C0A0?\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}