use strict;
my $str = '23456\\thttp://some.url/path/to/resource\\t\\x03U\\x1D\\x1F\\x04D0B0@\\xA0>\\xA0<\\x86:http://some.url/path/to/resource\\x06\\x08+\\x06\\x01\\x05\\x05\\x07\\x01\\x01\\x04C0A0?\\n';
my $regex = qr/^[0-9]+(?:\\t[^\\]*(?:\\(?![trn])[^\\]*)*){2}(?:\\r)?(?:\\n)$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}