$re = '/^[0-9]+(?:\\\\t[^\\\\]*(?:\\\\(?![trn])[^\\\\]*)*){2}(?:\\\\r)?(?:\\\\n)$/';
$str = '23456\\thttp://some.url/path/to/resource\\t\\x03U\\x1D\\x1F\\x04D0B0@\\xA0>\\xA0<\\x86:http://some.url/path/to/resource\\x06\\x08+\\x06\\x01\\x05\\x05\\x07\\x01\\x01\\x04C0A0?\\n';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);