package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\d{1,3}\.?)+(,\d{2}))`)
var str = `- João da Silva número 123456 com o valor de R$:6.298,65
- João da Silva número 123456 com o valor de R$:6.298,65
- João da Silva número 123456 com o valor de R$:298,65
- João da Silva número 123456 com o valor de R$:98,65
- João da Silva número 123456 com o valor de R$:8,65
- João da Silva número 123456 com o valor de R$:26.298,65
- João da Silva número 123456 com o valor de R$:726.298,65
- João da Silva número 123456 com o valor de R$:8.726.298,65
- João da Silva número 123456 com o valor de R$:8.726.298
- João da Silva número 123456 com o valor de R$:26.298`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}