const regex = /((\d{1,3}\.?)+(,\d{2}))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d{1,3}\\.?)+(,\\d{2}))', 'g')
const str = `- João da Silva número 123456 com o valor de R\$:6.298,65
- João da Silva número 123456 com o valor de R\$:6.298,65
- João da Silva número 123456 com o valor de R\$:298,65
- João da Silva número 123456 com o valor de R\$:98,65
- João da Silva número 123456 com o valor de R\$:8,65
- João da Silva número 123456 com o valor de R\$:26.298,65
- João da Silva número 123456 com o valor de R\$:726.298,65
- João da Silva número 123456 com o valor de R\$:8.726.298,65
- João da Silva número 123456 com o valor de R\$:8.726.298
- João da Silva número 123456 com o valor de R\$:26.298`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}