// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\d{1,3}\.?)+(,\d{2}))").unwrap();
let string = "- João da Silva número 123456 com o valor de R$:6.298,65
- João da Silva número 123456 com o valor de R$:6.298,65
- João da Silva número 123456 com o valor de R$:298,65
- João da Silva número 123456 com o valor de R$:98,65
- João da Silva número 123456 com o valor de R$:8,65
- João da Silva número 123456 com o valor de R$:26.298,65
- João da Silva número 123456 com o valor de R$:726.298,65
- João da Silva número 123456 com o valor de R$:8.726.298,65
- João da Silva número 123456 com o valor de R$:8.726.298
- João da Silva número 123456 com o valor de R$:26.298";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}