import re
regex = re.compile(r"((\d{1,3}\.?)+(,\d{2}))")
test_str = ("- João da Silva número 123456 com o valor de R$:6.298,65\n"
"- João da Silva número 123456 com o valor de R$:6.298,65\n"
"- João da Silva número 123456 com o valor de R$:298,65\n"
"- João da Silva número 123456 com o valor de R$:98,65\n"
"- João da Silva número 123456 com o valor de R$:8,65\n"
"- João da Silva número 123456 com o valor de R$:26.298,65\n"
"- João da Silva número 123456 com o valor de R$:726.298,65\n"
"- João da Silva número 123456 com o valor de R$:8.726.298,65\n"
"- João da Silva número 123456 com o valor de R$:8.726.298\n"
"- João da Silva número 123456 com o valor de R$:26.298")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")