#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:, ?)|(\w$)"
Local $sString = "prop1, prop2" & @CRLF & _
"" & @CRLF & _
"prop3, prop4, prop5,prop6" & @CRLF & _
"" & @CRLF & _
"prop7" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// other attempts" & @CRLF & _
"((?:(\w+)(?:, ?)?)+)" & @CRLF & _
"$2: ;\n" & @CRLF & _
"" & @CRLF & _
"(?:(.+)(, ?))+(.+)" & @CRLF & _
"$1: ;\n$3: ;" & @CRLF & _
"" & @CRLF & _
"(?:(\w+)(, ?))+(.+)" & @CRLF & _
"$1: ;\n$3: ;" & @CRLF & _
"" & @CRLF & _
"(?:, ?)|(\w$)" & @CRLF & _
"$1: ;\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")