$re = '/(?:, ?)|(\w$)/m';
$str = 'prop1, prop2
prop3, prop4, prop5,prop6
prop7
// other attempts
((?:(\\w+)(?:, ?)?)+)
$2: ;\\n
(?:(.+)(, ?))+(.+)
$1: ;\\n$3: ;
(?:(\\w+)(, ?))+(.+)
$1: ;\\n$3: ;
(?:, ?)|(\\w$)
$1: ;\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);