const regex = /(?:, ?)|(\w$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:, ?)|(\\w$)', 'gm')
const str = `prop1, prop2
prop3, prop4, prop5,prop6
prop7
// other attempts
((?:(\\w+)(?:, ?)?)+)
\$2: ;\\n
(?:(.+)(, ?))+(.+)
\$1: ;\\n\$3: ;
(?:(\\w+)(, ?))+(.+)
\$1: ;\\n\$3: ;
(?:, ?)|(\\w\$)
\$1: ;\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}