import re
regex = re.compile(r"(?:, ?)|(\w$)", flags=re.MULTILINE)
test_str = ("prop1, prop2\n\n"
"prop3, prop4, prop5,prop6\n\n"
"prop7\n\n\n"
"// other attempts\n"
"((?:(\\w+)(?:, ?)?)+)\n"
"$2: ;\\n\n\n"
"(?:(.+)(, ?))+(.+)\n"
"$1: ;\\n$3: ;\n\n"
"(?:(\\w+)(, ?))+(.+)\n"
"$1: ;\\n$3: ;\n\n"
"(?:, ?)|(\\w$)\n"
"$1: ;\\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")