#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b([0-F]+)\b"
Local $sString = "9"
Local $sSubst = "0$1~0123456789ABCDEF0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)