package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b([0-F]+)\b`)
var str = `9`
var substitution = "0$1~0123456789ABCDEF0"
fmt.Println(re.ReplaceAllString(str, substitution))
}