const regex = /\b([0-F]+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([0-F]+)\\b', 'g')
const str = `9`;
const subst = `0$1~0123456789ABCDEF0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);