use strict;
my $str = '9';
my $regex = qr/\b([0-F]+)\b/p;
my $subst = '0$1~0123456789ABCDEF0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";