#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\S+\s+){6}(\d+)"
Local $sString = "080323 1051 0004 7 9 888 89818888888 140 7 010 4" & @CRLF & _
"080323 1052 0002 9 888 6999 989818888888 7 001 0" & @CRLF & _
"080323 1052 0002 9 888 140 989818888888 7 001 0" & @CRLF & _
"080323 1349 0003 A 9 888 89517777777 178 3 029 4" & @CRLF & _
"080323 1447 0000 A 9 888 89517777777 178 3 007 4" & @CRLF & _
"080323 1448 0003 A 9 888 89517777777 178 3 008 4" & @CRLF & _
"080323 1925 0000 9 888 524 989217777777 7 002 0" & @CRLF & _
"080323 1925 0000 7 888 5651 524 7 003 4" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")