// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\S+\s+){6}(\d+)").unwrap();
let string = "080323 1051 0004 7 9 888 89818888888 140 7 010 4
080323 1052 0002 9 888 6999 989818888888 7 001 0
080323 1052 0002 9 888 140 989818888888 7 001 0
080323 1349 0003 A 9 888 89517777777 178 3 029 4
080323 1447 0000 A 9 888 89517777777 178 3 007 4
080323 1448 0003 A 9 888 89517777777 178 3 008 4
080323 1925 0000 9 888 524 989217777777 7 002 0
080323 1925 0000 7 888 5651 524 7 003 4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}